Home > Networking > Cisco > Config cisco router NAT to access internet

Config cisco router NAT to access internet

Teaching Guide: How to Configure Cisco Router NAT to Access the Internet

Level: Beginner (Zero IT Knowledge)

What is Cisco Router NAT?

Cisco router NAT (Network Address Translation) is a way to let devices on your private network (like your home or office) connect to the internet using a single public IP address. Think of NAT as a translator—it changes your private IP addresses into a public one that the internet understands. In this guide, you’ll learn how to set up Cisco router NAT step-by-step so your network can access the internet.

Step 1: Enter Configuration Mode

  • Start by accessing the router:
enable
configure terminal
  • What it does: Gives you permission to change settings.

Step 2: Configure Interfaces

  • Set up the inside interface (connected to your private network):
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no shutdown
  • Set up the outside interface (connected to the internet):
interface Serial0/0/0
 ip address 203.0.113.1 255.255.255.252
 ip nat outside
 no shutdown
  • What it does: ip nat inside marks the private side, and ip nat outside marks the internet side.

Step 3: Set Up NAT Overload

  • Enable NAT to share the public IP:
ip nat inside source list 1 interface Serial0/0/0 overload
  • Define which IPs can use NAT:
access-list 1 permit 192.168.1.0 0.0.0.255
  • What it does: overload lets many private IPs share one public IP (203.0.113.1).

Step 4: Add a Default Route

  • Tell the router where the internet is:
ip route 0.0.0.0 0.0.0.0 203.0.113.2
  • What it does: Sends all unknown traffic to the next router (e.g., ISP).

Step 5: Save Your Work

exit
end
write memory

Full Config Example

enable
configure terminal
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no shutdown
interface Serial0/0/0
 ip address 203.0.113.1 255.255.255.252
 ip nat outside
 no shutdown
ip nat inside source list 1 interface Serial0/0/0 overload
access-list 1 permit 192.168.1.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 203.0.113.2
exit
end
write memory

Practice Task

  1. Set up a PC with IP 192.168.1.2 (gateway 192.168.1.1).
  2. Connect it to GigabitEthernet0/0 on the router in Packet Tracer.
  3. Simulate the internet with another router (IP 203.0.113.2 on Serial0/0/0).
  4. Ping 203.0.113.2 from the PC to test internet access.

How to Test It Works

  • From the router:
show ip nat translations
  • Look for private IPs (e.g., 192.168.1.2) mapped to 203.0.113.1.
  • From the PC, ping the internet:
ping 203.0.113.2
  • Success means Cisco router NAT is working!

Why Cisco Router NAT Matters

  • Saves public IP addresses by sharing one.
  • Connects private networks to the internet securely.


Leave a Comment